ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Adams" <Jim.Ad...@sas.com>
Subject Trouble using version ranges
Date Thu, 07 Jun 2007 15:48:20 GMT
I have a private repo setup with the pattern ${dir}/[module]_[revision]/META-INF/ivy.xml

When I have an ivy file that contains a dependency with a verison range, it seems to be searching
the repo for the version range as if it were a static range. For instance:
<dependency name="foo" rev="[3.2.0,4.0.0["/>
Results in something like this in the ant output:
[ivy:retrieve]          module not found: [ foo | [3.2.0,4.0.0[ ]
[ivy:retrieve]                  ivyfiles: tried C:/ivy/913Repo/foo_[3.2.0,4.0.0[/META-INF/ivy.xml
[ivy:retrieve]                  ivyfiles: tried C:/ivy/913Repo/foo_[[3.2.0,4.0.0[]/META-INF/ivy.xml

It is not clear what I have to set in the conf file to enable version ranges.

Jim Adams
Jim.Adams@sas.com
Principal Systems Developer
SAS Institute


Mime
View raw message