ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: repreport problems
Date Thu, 14 Jun 2007 14:22:41 GMT
On 6/14/07, James Poli <James.Poli@sas.com> wrote:
>
> Hello,
>
> We've created an ivy repository only containing ivy.xml files that point
> to our already built jar repository.  Our
> resolver works fine with our pattern's (note no organisation) of:
>
> <ivy pattern="<ivy repo location>/[module]_[revision]/META-INF/ivy.xml" />
> <artifact pattern="<jar repo
> location>/[module]_[revision]/[artifact].[ext]" />
>
> But when I run repreport I get:
> ...
> [ivy:repreport] unable to list organisation in
> /sasusr/playpens/japoli/repo_JUN06_1250_gvjr/[module]_[revision]/META-INF/ivy.xml:
> token not found in pattern
> ...
>
> Question: Is there a way I generate a report if our repository(s)  don't
> contain an organisation in the directory structure?  We've
>                stored the organisation in our ivy.xml files.


The repreport task is still too limited ATM, and does not support
repositories with no organisation token. We also have a bug with
m2compatible repos. Please open a JIRA issue requesting this enhancement.

Xavier

Thanks in advance,
> Jim
>
>
>


-- 
Xavier Hanin - Independent Java Consultant
Manage your dependencies with Ivy!
http://incubator.apache.org/ivy/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message