ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos <csa...@netscape.net>
Subject Ant install task not working when trying to parse Struts2 or xwork 2.0.6 POMs
Date Tue, 12 Jun 2007 15:13:19 GMT

Hello. I am using Ivy 1.4.1 and a local repository. I have an "install" Ant
target that uses the ivy install task to download new modules from ibiblio.
It worked fine until I tried to install
org.apache.struts|struts2-core|2.0.6, it says that it cannot parse the POM
because there is no groupId.

The (verbose) output from Ant is

Apache Ant version 1.7.0 compiled on December 13 2006
Buildfile: build.xml
Detected Java version: 1.5 in: c:\java\jdk1.5.0_11\jre
Detected OS: Windows XP
....

ivy-install-module:
[ivy:install] :: installing [ org.apache.struts | struts2-core | 2.0.6 ] ::
[ivy:install] :: resolving dependencies ::
[ivy:install] 	ibiblio-maven2: found md file for [ org.apache.struts |
struts2-core | 2.0.6 ]
[ivy:install] 		=>
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom
(2.0.6)
[ivy:install] 	ibiblio-maven2: downloading
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom
[ivy:install] 	ibiblio-maven2: downloading
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom.sha1
[ivy:install] sha1 OK for
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom
[ivy:install] problem occured while resolving dependency: [
org.apache.struts | struts2-core | 2.0.6 ] {default=[*]} with
ibiblio-maven2: java.text.ParseException: no groupId found in pom in
file:/c:/DOCUME~1/XXXX/LOCALS~1/Temp/ivy48370xml
[ivy:install] 	ibiblio-maven2-nonamespace: found md file for [
org.apache.struts | struts2-core | 2.0.6 ]
[ivy:install] 		=>
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom
(2.0.6)
[ivy:install] 	ibiblio-maven2-nonamespace: downloading
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom
[ivy:install] 	ibiblio-maven2-nonamespace: downloading
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom.sha1
[ivy:install] sha1 OK for
http://www.ibiblio.org/maven2/org/apache/struts/struts2-core/2.0.6/struts2-core-2.0.6.pom
[ivy:install] problem occured while resolving dependency: [
org.apache.struts | struts2-core | 2.0.6 ] {default=[*]} with
ibiblio-maven2-nonamespace: java.text.ParseException: no groupId found in
pom in file:/c:/DOCUME~1/XXXX/LOCALS~1/Temp/ivy48372xml


Also, if I try to install opensymphony|xwork|2.0.6 I get a similar error


ivy-install-module:
[ivy:install] :: installing [ opensymphony | xwork | 2.0.1 ] ::
[ivy:install] :: resolving dependencies ::
[ivy:install] 	ibiblio-maven2: found md file for [ opensymphony | xwork |
2.0.1 ]
[ivy:install] 		=>
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom
(2.0.1)
[ivy:install] 	ibiblio-maven2: downloading
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom
[ivy:install] 	ibiblio-maven2: downloading
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom.sha1
[ivy:install] sha1 OK for
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom
[ivy:install] ERROR: 	ibiblio-maven2: bad organisation found in
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom:
expected='opensymphony' found='org.apache.maven.plugins'
[ivy:install] ERROR: 	ibiblio-maven2: bad module name found in
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom:
expected='xwork found='maven-idea-plugin'
[ivy:install] ERROR: 	ibiblio-maven2: bad revision found in
http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom:
expected='2.0.1 found='2.0-beta-5'
[ivy:install] problem occured while resolving dependency: [ opensymphony |
xwork | 2.0.1 ] {default=[*]} with ibiblio-maven2: java.text.ParseException:
inconsistent module descriptor file found in
'http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom':
bad organisation: expected='opensymphony' found='org.apache.maven.plugins';
bad module name: expected='xwork' found='maven-idea-plugin'; bad revision:
expected='2.0.1' found='2.0-beta-5'; 
.....

[ivy:install] java.text.ParseException: inconsistent module descriptor file
found in
'http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom':
bad organisation: expected='opensymphony' found='org.apache.maven.plugins';
bad module name: expected='xwork' found='maven-idea-plugin'; bad revision:
expected='2.0.1' found='2.0-beta-5'; 
[ivy:install] java.text.ParseException: inconsistent module descriptor file
found in
'http://www.ibiblio.org/maven2/opensymphony/xwork/2.0.1/xwork-2.0.1.pom':
bad organisation: expected='opensymphony' found='org.apache.maven.plugins';
bad module name: expected='xwork' found='maven-idea-plugin'; bad revision:
expected='2.0.1' found='2.0-beta-5'; 


I don't know if this is a problem with ibiblio's POMs, with Ivy or with my
scripts. Any help would be appreciated.

Thanks,

Carlos

P.S.: I have tried with Ivy 2.0-alpha1, but then things went much worse, it
looks like a bug: it does not download the POM because it tries to get it
from the filesystem repository (the "to" attributed in the install task,
instead of the "from").

-- 
View this message in context: http://www.nabble.com/Ant-install-task-not-working-when-trying-to-parse-Struts2-or-xwork-2.0.6-POMs-tf3908161.html#a11080760
Sent from the ivy-user mailing list archive at Nabble.com.


Mime
View raw message