ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject My first build of Ivy
Date Fri, 11 May 2007 12:26:00 GMT
I just did my first build of Ivy. So here my first thoughts on the
output:

Revision: 537162
Proxy not configured
Build command: ant

init:             ...
prepare:          ...
compile-core:	...
compile-ant:	...
init-ivy:
[ivy:configure] Loading ... ivy.properties
[ivy:configure] :: Ivy non official version ::
http://incubator.apache.org/ivy/ ::
[ivy:configure] impossible to define new type: class not found:
org.apache.ivy.plugins.resolver.VsftpResolver in [] nor Ivy classloader
[ivy:configure] impossible to define new type: class not found:
...SshResolver in [] ...
[ivy:configure] impossible to define new type: class not found:
....VfsResolver in [] ...
[ivy:configure] impossible to define new type: class not found:
....SFTPResolver in [] ...
[ivy:configure] :: loading settings :: file = ... ivysettings.xml
[ivy:configure] DEPRECATED: 'ivyconf' element is deprecated, use
'ivysettings' instead (... ivysettings.xml )
[ivy:configure] DEPRECATED: 'conf' is deprecated, use 'settings' instead
(... ivysettings.xml)

resolve:
[ivy:retrieve] :: resolving dependencies :: [ apache | ivy |
working@nb011696 ]
[ivy:retrieve]  confs: [default, test]
[ivy:retrieve] You probably access the destination server through a
proxy server that is not well configured.
[ivy:retrieve] You probably access the destination server through a
proxy server that is not well configured.
...

[ivy:retrieve] :: resolution report ::
 
---------------------------------------------------------------------
        |                  |            modules            ||
artifacts   |
        |       conf       | number| search|dwnlded|evicted||
number|dwnlded|
 
---------------------------------------------------------------------
        |      default     |   6   |   0   |   0   |   0   ||   0   |
0   |
        |       test       |   1   |   0   |   0   |   0   ||   0   |
0   |
 
---------------------------------------------------------------------

BUILD FAILED
C:\ant\svn-repository\ivy\core\build.xml:150: impossible to resolve
dependencies: java.lang.NullPointerException



1. target "init-ivy": 
   - why do you use deprecated elements in your own configuration?
(ivyconf-->ivysettings, conf-->settings)
2. target "resolve": 
   - I got 22 messages "You probably access ..." - so many? One would be
enough ...
   - How to set proxy?
3. build result "build.xml:150: impossible to resolve dependencies:
java.lang.NullPointerException"
   build.xml:150:   <ivy:retrieve conf="default,test" />
   - You should catch a NPE and provide a useful message.



I cant provide a patch or deeper ideas because of not knowing the
sources yet ;-)



Jan

Mime
View raw message