ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeffrey.blatt...@yahoo.com
Subject Re: resolving maven snapshot versions
Date Fri, 11 May 2007 20:11:25 GMT
okay i see the first problem. the artifact in the maven repo is a WAR file, but ivy is looking
for a JAR file,

[ivy:install]           tried https://portal.dev.java.net/nonav/repository/com/sun/portal/rssportlet/1.1-SNAPSHOT/rssportlet-1.1-SNAPSHOT.jar
[ivy:install] CLIENT ERROR: Not Found url=https://portal.dev.java.net/nonav/repository/com/sun/portal/rssportlet/1.1-SNAPSHOT/rssportlet-1.1-SNAPSHOT.jar

the pattern i am using in my resolver is ...

https://portal.dev.java.net/nonav/repository/[organisation]/[module]/[revision]/[artifact]-[revision].[ext]

using a url resolve, with m2compat set to true.

???

----- Original Message ----
From: jeff <farble1670@yahoo.com>
To: ivy users <ivy-user@incubator.apache.org>
Sent: Friday, May 11, 2007 11:37:23 AM
Subject: resolving maven snapshot versions

i am trying to resolve a dependency that is installed as a maven2 snapshot version (1.1-SNAPSHOT).
by default, that doesn't seem to work.

i imagine this has something to do w/ specifying a matcher on the ivy:install task, but it
isn't obvious what i need to do here. i suppose it also might have to do w/ the pattern used
on the resolver ... ?

???

thanks.
 



       
____________________________________________________________________________________Yahoo!
oneSearch: Finally, mobile search 
that gives answers, not web links. 
http://mobile.yahoo.com/mobileweb/onesearch?refer=1ONXIC






       
____________________________________________________________________________________Looking
for a deal? Find great prices on flights and hotels with Yahoo! FareChase.
http://farechase.yahoo.com/
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message