ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Schoepfer <t.schoep...@daetwyler-graphics.ch>
Subject Conflict problem
Date Thu, 03 May 2007 16:31:46 GMT
Hi

I currently try to use ivy for a small repository.
I'm stuck upon configuration.

My repo contains 4 modules:
- Common 1.0.0
- Common 1.1.0
- Runtime 2.3
- Runtime 2.4

App_A depends Runtime 2.3 and Common 1.+
App_B depends Runtime 2.4 and Common 1.+
Common 1.0.0 depends Runtime 2.3
Common 1.1.0 depends Runtime 2.4

I can resolve App_B.
- This selects Common 1.1.0 and Runtime 2.4.

Resolution of App_A fails.
- It selects Runtime 2.3 (as expected)
- It selects Common 1.1.0 (instead of 1.0.0)

defaultConflictManager is set to "strict"

Can ivy be configured to try other revs, if the easiest path fails?

Regards
-- 
Thomas Schöpfer

Mime
View raw message