ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Quenot <...@apache.org>
Subject Ivy file not published when using specific configuration
Date Wed, 23 May 2007 08:08:02 GMT
Hi there,

I'm using <ivy:publish>  to publish the artifacts  generated by my
build to  a local  repository.  This  works well,  until I  had to
specify conf="default" to avoid  publishing for examples WAR files
to  the repository  (belongs to  configuration "webapp").   When I
added this  attribute, Ivy  files stopped  being published  to the
repository, and building other modules depending on this published
artifact failed  with the following error  (with anonymized module
names):

[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve] 	problem while downloading ivy file: /path/to/local/repo/organisation/artifact/1.0-dev-20070523072416/ivy.xml
to /var/tmp/ivy51894xml: /path/to/local/repo/organisation/artifact/1.0-dev-20070523072416/ivy.xml
(No such file or directory)
[ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 		::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 		:: [ organisation | artifact | latest.development ]: null
[ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

Notice the word "null" at the end of the module descriptor.  This is Ivy 1.4.1.

Your help will be appreciated.
-- 
     Jean-Baptiste Quenot
aka  John Banana   Qwerty
http://caraldi.com/jbq/

Mime
View raw message