ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Macaulay" <robert.macau...@gmail.com>
Subject Is this a bug with strict conflict manager? Or does it not support ranges?
Date Mon, 09 Apr 2007 02:56:12 GMT
If I use
defaultConflictManager="strict"

I get this
[ extern | commons-logging | 1.1 ] (needed by [[ extern |
spring-framework | 2.0.2 ], [ ubs | laredo | working@whou0128628 ]])
conflicts with [ extern | commons-logging | [1.0.4,) ] (needed by [[
extern | hibernate | 3.2.1 ]])

It looks like the strict ConflictManager does not support the range
support 1.1 != [1.0.4,)  One package is requesting 1.1, the other is
asking for 1.0.4 or greater. Seems like the both should be happy with
1.1. Is this possible? Thanks

Mime
View raw message