ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeff <jeffrey.blatt...@yahoo.com>
Subject Re: 1.4.1 -> 2.x (trunk), problem with resolvers ...
Date Fri, 20 Apr 2007 23:51:16 GMT
i got around this by adding a "default resolver" in my settings. not sure why this was required
... isn't that what the "from" attribute on the install tag is for?

jeff <jeffrey.blattman@yahoo.com> wrote: i am trying to use a locally built version
of ivy in place of 1.4.1. i run "ant install" and it copies ivy.jar into ~/.ivy/jars ... ok
all is good so far. the only change i made was ivyconf to ivysettings, as it said the former
is deprecated.

when i run my ant project that uses ivy, it doesn't appear to be using any of the resolvers
i set up. it just fails to find them (no delay, as if it was going through my chain checking).
the output is below.

has something changed in 2.x? i don't see any relevant errors ... i attached my ivysettings.xml.
 

Buildfile: build.xml

init-ivy-user-home:

init-ivy-local-home:

init-ivy-jar:

init-ivy-home:

download-ivy:
      [get] Getting: http://people.apache.org/~antoine/ivy/ivy-1.4.1.jar
      [get] To: /Users/jtb/.ivy/jars/ivy.jar
      [get] Not modified - so not downloaded

check-ivy-available:

init-ivy:
   [antlib] EMMA: collecting runtime coverage data ...

init:
[ivy:configure] Loading jar:file:/Users/jtb/.ivy/jars/ivy.jar!/org/apache/ivy/core/settings/ivy.properties
[ivy:configure] :: Ivy 2.0.0-alpha-1-incubating-local-20070420160130 - 20070420160130 :: http://incubator.apache.org/ivy/
::
[ivy:configure] :: loading settings :: file = /Users/jtb/src/dependencies/ivysettings.xml

install-external:
[ivy:install] ::  installing [ com.sun.dsame | sdk | 7.0 ] ::
[ivy:install] :: resolving dependencies ::
[ivy:install] :: downloading artifacts to cache ::
[ivy:install] :: installing in local ::
[ivy:install] :: install resolution report ::
        ---------------------------------------------------------------------
        |                  |             modules            ||   artifacts   |
        |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
        ---------------------------------------------------------------------
        |      default     |   1   |   0   |   0   |   0   ||   0   |   0   |
        ---------------------------------------------------------------------

BUILD FAILED
/Users/jtb/src/dependencies/build.xml:12: install failed - see output for details

Total time: 4 seconds
EMMA: runtime coverage data merged into [/Users/jtb/src/dependencies/coverage.ec] {in 152
ms}
           

---------------------------------
Ahhh...imagining that irresistible "new car" smell?
 Check out new cars at Yahoo! Autos. 

    

    

    

    


    

    

 
    

    
    

    
    
                    
            
                
                
            
            
                
             
            
                name="ibiblio-maven" 
                root="${ibiblio-maven-root}" 
                pattern="${ibiblio-maven-pattern}"
                m2compatible="false"
            />            
            
                name="ibiblio-maven2" 
                root="${ibiblio-maven2-root}" 
                pattern="${ibiblio-maven2-pattern}"
                m2compatible="true"
            />
            
                                
              
            
                                
              
            
                                
              
        
    











       
---------------------------------
Ahhh...imagining that irresistible "new car" smell?
 Check outnew cars at Yahoo! Autos.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message