ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nascif Abousalh-Neto" <Nascif.AbousalhN...@sas.com>
Subject RE: problems with simple configuration
Date Thu, 22 Mar 2007 12:45:21 GMT
Sounds like a good idea - version the documentation to match the code.
/Nascif

-----Original Message-----
From: Xavier Hanin [mailto:xavier.hanin@gmail.com] 
Sent: Thursday, March 22, 2007 6:41 AM
To: ivy-user@incubator.apache.org
Subject: Re: problems with simple configuration

On 3/22/07, Gilles Scokart <gscokart@gmail.com> wrote:
>
> The ivy-settings have been added recently in the version under 
> development.
> Maybe there is an error in the packaged jar that you are using, or you 
> might have 2 ivy.jar (one old and one new) loaded in an unexpected 
> way.


Yes, the current online doc reflect the changes of the upcoming version, but this is confusing.
Maybe we should provide an online version of 1.4documentation, and one of 1.5, so that people
can use the one they want.

WDYT?

- Xavier

Gilles
>
> > -----Original Message-----
> > From: Simon [mailto:simonzmail@gmail.com]
> > Sent: jeudi 22 mars 2007 9:48
> > To: ivy-user@incubator.apache.org
> > Subject: problems with simple configuration
> >
> > Hi,
> >
> > I just started looking at ivy and it seems like a very nice tool.
> > However I ran into problems as soon as I tried to customize the 
> > configuration.  It works fine with the default (ie. no) configuration.
> >  When I make an ivysettings.xml file with what the tutorial says is 
> > the default configuration for ivy:
> >
> > <ivysettings>
> >   <settings defaultResolver="default"/>
> >   <include url="${ivy.default.conf.dir}/ivysettings-public.xml"/>
> >   <include url="${ivy.default.conf.dir}/ivysettings-shared.xml"/>
> >   <include url="${ivy.default.conf.dir}/ivysettings-local.xml"/>
> >   <include url="${ivy.default.conf.dir}/ivysettings-main-chain.xml"/>
> >   <include 
> > url="${ivy.default.conf.dir}/ivysettings-default-chain.xml"/>
> > </ivysettings>
> >
> > it fails with errors:
> >
> > c:\testivy\build.xml:15: impossible to configure ivy with given file:
> > c:\testivy\ivy-settings.xml :java.text.ParseException: failed to 
> > configure with file:/c:/testivy/ivy-settings.xml: problem in config
> > file: JAR entry org/apache/ivy/core/settings/ivysettings-public.xml
> > not found in c:\programs\apache-ant-1.7.0\lib\ivy.jar
> >
> > I looked in the ivy.jar file and it doesn't seem to have those xml
> > files in it, even though the tutorial says it should.   Can anybody
> > explain why the default configuration doesn't work when it's 
> > specified explicitly, or what else to put in the ivysettings file to 
> > get the default behavior?
> >
> > Sorry if this is a dumb question - thanks in advance for any help!
> >
> > Cheers,
> >
> > Simon.
>
>

Mime
View raw message