ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject incompatible dependencies
Date Tue, 20 Mar 2007 13:56:58 GMT
Hi,

we have some libraries which may not used together.

For instance, 
- say we have module A-1.0, A-2.0, B and C. 
- B doesn't have a dependency on A, but B cannot be used together with A-1.0. However, B can
be used together with A-2.0.
- C has a dependency on both B and A-1.0

What is the best way to configure Ivy so that it fails when I try to resolve the dependencies
of module C?
Manual checking this in Ant after a resolve could be an option, but I want to enforce this
in IvyDE as well...

regards,
Maarten





 
____________________________________________________________________________________
8:00? 8:25? 8:40? Find a flick in no time 
with the Yahoo! Search movie showtime shortcut.
http://tools.search.yahoo.com/shortcuts/#news

Mime
View raw message