ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Korobskiy <dk.r...@verizon.net>
Subject Re: Eclipse integration
Date Thu, 08 Mar 2007 02:52:49 GMT
Hi, Nascif
Re: your e-mail from Wednesday, March 7, 2007 5:47 PM

NAN> Another newbie question - does Ivy provide any support to alert the user
NAN> that it is time to update the dependency versions in ivy.xml?

NAN> For example, an IDE view of the repository with decorators showing which dependencies
are "out-of-date"?

NAN> One of the most common fears I encounter when "evangelizing" the
NAN> dependency management approach is that developers will stay too long on
NAN> their "island of code" while their dependencies drift away to newer and
NAN> newer versions. I am trying to think of ways that would make it easier to
NAN> enforce some kind of motility - and a visual indication that your
NAN> dependencies are getting old would be a great help.

NAN> Perhaps some way of failing the resolve task if ivy.xml has more then X% old dependencies...

NAN> Does anybody has a similar use case?

If you are simply trying to "get the latest version" you can use dynamic revisions in your
Ivy files (for example,
<dependency name="commons-logging" rev="latest.integration" conf="default"/>

Perhaps, I am not quite understanding what you are trying to achieve.

Dmitriy <1-127-441 @ICQ, DKroot @Skype, DKroot1 @AIM, dkroot1_at_gmail_dot_com @Google
Talk>


Mime
View raw message