Chas,
does your repository contain the file hibernate/hibernate/ivy-3.0.5.xml? Does it contain the dependencies for Hibernate?

Regards,
Stephen


Chas Douglass <chas.douglass@gmail.com>

07/02/2007 03:31 AM
Please respond to
ivy-user@incubator.apache.org

To
ivy-user@incubator.apache.org
cc
Subject
New user, no transitive dependencies





-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I'm trying to get my first Ivy build to work, and I'm missing something
basic, I think.

I have an ivy.xml file that has:

(preamble stuff deleted)
 <dependencies>
   <dependency org="hibernate" name="hibernate" rev="3.0.5"/>
 <dependencies>

And I use the simplest case:

 <ivy:retrieve pattern="${target.lib.dir}/[artifact].[ext]"/>

in my build.xml file.

This correctly downloads hibernate.jar version 3.0.5, but none if it's
transitive dependencies.

I tried adding 'transitive="true"', which the documents say is the
default anyway, and got no difference.

What am I missing?

Thanks.

Chas Douglass
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (Cygwin)

iD8DBQFFyK0z7MXbHcSlZeMRAv9BAKCYK2MlCVuNDLdsC6h90ZWS4kUuMQCfQbzj
FSyTjE1QpGvNClo2V6cRMoE=
=uXpS
-----END PGP SIGNATURE-----