ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Gill" <llign...@gmail.com>
Subject Re: Ivy reports - nullpointer exception
Date Tue, 13 Feb 2007 13:36:51 GMT
Don't know, so I'm going to go for the obvious stuff... Are you all building
on the same platform, same OS, same versions of java, same ivy versions,
same ant versions, same ant (other) plugins in ant lib?
Do you have classpath environment variable set to something different on
different machines? Setting classpath environment variables is a bad idea
BTW...

Is your build system hand assembled, or setup automagically somehow? The
system I put together requires ant out of the box, and one environment
variable pointing to networked drive with a repository where other bits of
the system are (like ivy, ivyconf, etc). That way you ensure you all have
the same setup.

On 2/13/07, Loehr, Ruel <rloehr@pointserve.com> wrote:
>
>
> Hey guys,
>
> I've just introduced ivy into our build system.   It's a nice project
> and works well.    Now on to mine question.......
>
>
> On my local box the ivy reports ant task works fine.   2 users have
> reported the following error:
>
> [ivy-report] Transforming into
> D:\Proyectos\projects\PointServe\ESO_3_0\dev\snm\build\bin\dependency-re
> ports
>
> [ivy-report] Processing C:\Documents and
> Settings\czuniga.AVANTICA\.ivy\cache\pointserve-eso-bdlclient.xml to
> D:\Proyectos\projects\PointServe\ESO_3_0\dev\snm\build\bin\dependency-re
> ports\pointserve-eso-bdlclient.html
>
> [ivy-report] Loading stylesheet C:\Documents and
> Settings\czuniga.AVANTICA\.ivy\cache\ivy-report.xsl
>
> [ivy-report] Processing C:\Documents and
> Settings\czuniga.AVANTICA\.ivy\cache\pointserve-eso-build.xml to
> D:\Proyectos\projects\PointServe\ESO_3_0\dev\snm\build\bin\dependency-re
> ports\pointserve-eso-build.html
>
> [ivy-report]
> C:/Documents%20and%20Settings/czuniga.AVANTICA/.ivy/cache/ivy-report.xsl
> :215:41: Fatal Error! Unknown error in XPath Cause:
> java.lang.NullPointerException
>
> [ivy-report] : Fatal Error! Fatal error during transformation Cause:
> Fatal error during transformation
>
> [ivy-report] Failed to process C:\Documents and
> Settings\czuniga.AVANTICA\.ivy\cache\pointserve-eso-build.xml
>
>
> I've tried recreating there error, deleting my cache and rebuilding, but
> cannot reproduce it.  I know there isn't much to go on here, but I'm
> hoping somebody has maybe seen something similar??   I couldn't find
> anything in the list archives....
>
> Any ideas on which direction I should take in reproducing this?
>
> Thanks!
> Ruel Loehr
>



-- 
Regards,
John Gill

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message