ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: 1.4.1 Slowness?
Date Tue, 26 Dec 2006 18:17:18 GMT
I really don't know what's happening, it's very strange. Does anybody else
have the same kind of trouble? What I suggest if you have time is to debug
using your favorite IDE and see what takes so long. You can also use a
profiler. The problem is that I'm not able to reproduce the problem, so I
can't help much...

Xavier

On 12/26/06, Eric Crahen <eric.crahen.lists@gmail.com> wrote:
>
> The url's are unresolvable right now, but I didn't think this should
> matter
> because
> I have no dependencies. And because I have those packages in my cache. The
> rest of ivy's debug output doesn't show it trying to resolve anything. It
> just prints
> the chain and continues.
>
> On 12/26/06, Eric Crahen <eric.crahen.lists@gmail.com> wrote:
> >
> > Yes, my ivyconfig is available locally. The last line output before the
> > timing information
> > is:
> >
> > [ivy:configure] setting 'ivy.default.always.check.exact.revision' to
> > 'false'.
> >
> > // delay
> >
> > [ivy:configure] configuration done (97962ms)
> > [ivy:configure]         default cache: /home/crahen/.ivy/cache
> > [ivy:configure]         default resolver: online
> > [ivy:configure]         default latest strategy: latest-revision
> > [ivy:configure]         default conflict manager: latest-revision
> > [ivy:configure]         circular dependency strategy: warn
> > [ivy:configure]         validate: true
> > [ivy:configure]         check up2date: true
> >
> >
> > My project has no dependencies.
> >
> > <chain>
> >   <cache/>
> >   <filesystem/>
> >   <ur/l>
> >   <url/>
> > </chain>
> >
> >
> >
> > On 12/26/06, Xavier Hanin <xavier.hanin@gmail.com> wrote:
> > >
> > > On 12/24/06, Eric Crahen <eric.crahen.lists@gmail.com> wrote:
> > > >
> > > > Using version 1.4.1 I've notived that ivy:configure takes an
> > > extrodinarily
> > > > long time. I have 1 resolver
> > > > configured, which is a local filesystem resolver and ant -d shows
> > > > ivy:configure took 26700 ms on average
> > > > on the last three runs.
> > >
> > >
> > > This is very strange. Is your ivyconf.xml file available locally? If
> not
> > > can
> > > you try with a local file? When you run it in debug mode, do you see a
> > > pause
> > > at some time? What is the last output before the pause?
> > >
> > > Xavier
> > >
> > >
> > > > Verbose ant trace doesn't show anything further. The
> > > > last line I see before the timing
> > > > information is:
> > > >
> > > > ivy.default.always.check.exact.revision being set to false.
> > > >
> > > > --
> > > >
> > > > - Eric
> > > >
> > > >
> > >
> > >
> >
> >
> > --
> >
> > - Eric
>
>
>
>
> --
>
> - Eric
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message