ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Grydholt Jensen" <grydh...@gmail.com>
Subject Re: Can't resolve dependencies in source distribution for 1.4.1
Date Mon, 04 Dec 2006 18:10:09 GMT
On 04/12/06, Xavier Hanin <xavier.hanin@gmail.com> wrote:
> On 12/4/06, Pierre H├Ągnestrand <pierre.hagnestrand@bwin.org> wrote:
> >
> > Hi
> > I downloaded the source from
> > http://jayasoft.org/visit.php?url=./downloads/ivy/1.4.1/ivy-1.4.1-src.zip
> > as it isn't possible to get it from
> > https://svn.apache.org/repos/asf/incubator/ivy/ yet.
> > But when I run ant from the prompt it couldn't resolve all dependencies.
> > It looks like some parts are missing in the jayasoft repository?
> > Do I do someting wrong or is the dependencies wrong?
>
>
> I think the problem is due to a migration of the server. The previous
> server, paid by jayasoft, is closing on wednesday, so until I find another
> solution I've migrated the server to a home machine. But I'm currently
> experiencing problems with svn (no more anonymous access, you have to use
> 'anonymous' as user with an empty password) and user loggin / sessions
> (seems that you can't stay logged in or something like that). The ivyrep
> server should be ok now, so you can try again. Sorry for the trouble.

I don't think that this is the fault of the jayasoft server. Instead,
it seems like the ibiblio server is missing some files. If one
navigates through the directory structure on the ibiblio server, the
jar-files for jsch and jdom seem to be there in the directory
listings. However, the files are links into thin air. I solved the
problem by pointing to another maven-mirror. I used

<artifact pattern="http://ibiblio.lsu.edu/main/maven/[module]/[type]s/[artifact]-[revision].[ext]"/>

instead of

<artifact pattern="http://www.ibiblio.org/maven/[mod
ule]/[type]s/[artifact]-[revision].[ext]"/>

I have also noticed the problems about the svn access, I'll try using
anonymous as user.

Best regards,

Jacob Grydholt Jensen

Mime
View raw message