ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Lee <c...@herzumsoftware.com>
Subject Re: using ssh with no username
Date Mon, 18 Dec 2006 19:43:36 GMT

I'm using mac os x 10.4, so when I do not provide a username in the  
XML attributes, it brings up the java prompt.  (even when i run ant  
from the terminal, it brings up the java swing prompt.)

After having looked in the CredentialUtil's class, I tried playing  
around with the code.  It seems to me that even though I can use the  
prompt to provide a username/password, there is another class that is  
overriding/discarding the username.  I did not dig deeper into it  
than that yet.

Christopher Lee

fourthcodex
Manager of Product Development
312.602.1028 (office)
312.952.3553 (cell)


On Dec 15, 2006, at 2:28 AM, Xavier Hanin wrote:

> On 12/13/06, Christopher Lee <clee@herzumsoftware.com> wrote:
>>
>> Hello all,
>> I'm very happy that Ivy now ships with a set of more secure  
>> resolvers, as
>> it will enable the use of Ivy for our internal projects.
>>
>> I've been having problems with the SSH resolver, and was wondering if
>> anyone could help me out.
>>
>> I want to set up my build script to publish using the ssh- 
>> resolver, but I
>> do not want to specify a username, so that ivy will prompt for a  
>> username
>> and password (instead of having to hard code it).  That way each  
>> developer
>> will have to login as themselves.
>>
>> however, it seems like if I do not specify the username, even when  
>> I enter
>> in the correct username/password (replacing guest) from the SSH  
>> prompt, it
>> cannot authenticate.
>>
>
> Which prompt are you talking about? I'm not sure which one is  
> really used in
> your case. Depending on your environment, sometime asking for  
> credentials is
> done directly by the system, sometimes it's Ivy which display a  
> dialog. If
> it's Ivy which asks for your creedentials, have a look at the
> CredentialsUtil class, and also the SshCache class. I can't tell  
> really more
> except that it has been tested in real life, but there is no unit  
> test, so
> we may have a regression... I can't test myself since I haven't a good
> environment for the moment.
>
> Xavier
>
> I'm trying to figure this out from the current code base, but I  
> haven't
>> identified the problem just yet.
>>
>> Any suggestions would be appreciated.  I do not want to have to  
>> use ssh
>> key's, as I do not want to have to set up each individual user's  
>> environment
>> with the keys.
>>
>>
>> Christopher Lee
>>
>> fourthcodex
>> Manager of Product Development
>>
>>
>>
>>


Mime
View raw message