ant-ivy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mykel Alvis" <my...@weirdness.com>
Subject Proxy issues
Date Mon, 20 Nov 2006 20:23:27 GMT
Hi,
I'm testing out ivy 1.4.1 for purposes of possibly integrating it into a
build stream and I can't seem to get the initial test to work for me.

I AM behind a National Socialistic-esque proxy firewall that does virus
checking on each and every file that comes across the internet connection,
but that's the
way it is here and nothing's likely to change in that respect.  Since I'm
working on a Linux box on this primarily Windows network, I get little to no
support for any proxy issues I experience.

I got a previous failure with "Server Redirected too many times".  Following
some incidental advice in a forum posting, I added the commons-httpclient to
my CLASSPATH before invoking ant.  This seemed to just cause a hanging of
the process.

I did add a line into the "test" build.xml file as follows, with the obvious
appropriate changes:

<setproxy proxyhost="PROXY.IP.HERE" proxypassword="mypass"
proxyuser="myuser" proxyport="PROXY.PORT" />

This also did not help.

I also set my http_proxy variable to the authenticated proxy location which
did not help.

The error seems typically to be " java.net.ConnectException Connection timed
out:  connect"  which might be expected if one were having difficulty
navigating an external connection.


I did not expand my  commons-httpclient logging yet, as it is starting to
seem as if this process might be more trouble than it's worth.

Is there anything else I need to try?

Mykel

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message