ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaikiran Pai <jaiki...@apache.org>
Subject Re: JDK 12 enters Rampdown Phase Two
Date Wed, 23 Jan 2019 07:56:01 GMT
Hi Rory,

On 21/01/19 4:45 PM, Rory O'Donnell wrote:
>  Hi Stefan/Jaikiran,
>
> **OpenJDK builds *- JDK 12 Early Access build 28 **is now available
> **at : - jdk.java.net/12/*
>
Our testsuite on Linux with this EA version of of JDK 12 has passed fine
without issues. Haven't had a chance to test on Windows yet.


>  
> **OpenJDK builds *- JDK 13 Early Access build 4 is **now available
> **at : - jdk.java.net/13/*


Our Ant testsuite against this EA version of JDK 13 has passed fine on
Linux. However, one of our other projects within the Ant umbrella has
shown an issue with the Jacoco library usage (which internally uses ASM
library). Narrowing this down to a simple standalone Java program has
shown that this version of Java isn't compatible with ASM 7.0. It runs into:


java.lang.IllegalArgumentException: Unsupported class file major version 57
    at org.objectweb.asm.ClassReader.<init>(ClassReader.java:184)
    at org.objectweb.asm.ClassReader.<init>(ClassReader.java:166)
    at org.objectweb.asm.ClassReader.<init>(ClassReader.java:152)


while trying to instrument a class compiled with that JDK 13 EA build. I
haven't yet had a chance to see if there's a newer version of ASM which
works against this version, but my quick checks haven't shown any newer
versions.


-Jaikiran



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message