ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gintautas Grigelionis <g.grigelio...@gmail.com>
Subject Re: [VOTE] Release Apache Ant 1.10.2 based on RC1
Date Mon, 05 Feb 2018 20:16:34 GMT
2018-02-05 21:02 GMT+01:00 Stefan Bodewig <bodewig@apache.org>:

> On 2018-02-05, Gintautas Grigelionis wrote:
>
> > Houston, we have a problem: JPMS explicitly forbids broken packages.
>
> Ant's jar can never be Java9 modules. If we wanted them to be modules,
> we'd have to move classes and seriously break backwards compatibility.
>
> Fortunately there is no reason for the jars to become modules.
>

Suppose an application (say, an IDE) would like to have all components on
module path rather than classpath.
Well, for now I'll remove the automatic module name from jars that cannot
be made into modules without breaking BWC.
That way we will know better what to expect eventually.

Gintas

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message