ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bodewig <...@git.apache.org>
Subject [GitHub] ant issue #53: Optional libraries for Ant 1.10
Date Wed, 27 Dec 2017 11:59:26 GMT
Github user bodewig commented on the issue:

    https://github.com/apache/ant/pull/53
  
    I see you've already merged this PR, I'll look st it later. I hope you didn't wait for
me to respond during Christmas.
    
    I'm not sure why `dest` is part of `fetch.xml`, we've always seen at as something for
the Ant developers and it really only sets the baseline Ant is compiled against. No more.
    
    I'm not sure which benefit you see with upgrading all those libraries as from my point
of view you are only updating what the binary distributions get compiled against (and only
if the release manager deletes the already existing local cache and re-runs `fetch.xml` which
is rather unlikely to happen). Either the API of the upgraded version remains compatible with
the older one so the update doesn't have any effect at all or it is not, in which case we
introduce a backwards incompatibility with no real win I can see. But that's just my opinion.
    
    There is a page inside of the manual - http://ant.apache.org/manual/install.html#librarydependencies
- that may need to get updated as well.


---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message