ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nlalevee <...@git.apache.org>
Subject [GitHub] ant-ivy issue #57: fix last inconsistencies in generics
Date Sun, 06 Aug 2017 22:11:49 GMT
Github user nlalevee commented on the issue:

    https://github.com/apache/ant-ivy/pull/57
  
    @twogee, you have looked into the open sources softwares that use Ivy, but Ivy is under
the ASL, not the GPL, it might be used in some closed, commercial products :)
    So we cannot know for sure that we won't break softwares by changing that part of the
API.
    
    The hierarchy of the classes of the DependencyResolver is not of the best design, it would
have been great to have more composition than inheritance. But that's we have. So unless we
want to break things, rewrite things and make an Ivy3, I think we should stick with it.
    
    To move forward, I suggest that this PR doesn't break the API at all. And if you still
think DependencyResolver deserve a probably-safe API break, you're welcomed to discuss it
on ant-dev so we can get a consensus.



---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message