ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sicker <boa...@gmail.com>
Subject Re: Minimum Java runtime version for proposed upcoming Ivy release
Date Thu, 18 May 2017 15:12:49 GMT
Using 1.7 for the next release and then 1.8 for the following release makes
sense to me.

On 18 May 2017 at 05:58, J Pai <jai.forums2013@gmail.com> wrote:

> +1
>
> -Jaikiran
> On 18-May-2017, at 4:26 PM, Jan Matèrne (jhm) <apache@materne.de> wrote:
>
> I would favour 1.7 as it's the newest before the major update to Java8.
> Having a 1.7 in the target environment should not been so restrictive ...
>
> Jan
>
> > -----Ursprüngliche Nachricht-----
> > Von: Paul King [mailto:paulk@asert.com.au]
> > Gesendet: Donnerstag, 18. Mai 2017 11:27
> > An: Ant Developers List
> > Betreff: Re: Minimum Java runtime version for proposed upcoming Ivy
> > release
> >
> > The current version of Groovy has 1.6 as the minimum but is our
> > maintenance stream.
> > The upcoming next version will require 1.7 and versions with 1.8 as the
> > minimum are not too far away.
> >
> > Ant 1.9.x is still on Java5 but Ant 1.10.x requires Java 8.
> >
> > I don't think Gradle uses any Ivy classes any more.
> >
> > I'd recommend 1.7 since most active projects will be releasing on
> > 1.7/1.8 and then after a release, if all goes well activity-wise, I'd
> > then bump the Ivy version and target 8.
> >
> > Cheers, Paul.
> >
> >
> > On Thu, May 18, 2017 at 7:14 PM, Nicolas Lalevée
> > <nicolas.lalevee@hibnet.org
> >> wrote:
> >
> >> I think that upgrading the requirement on the JDK is a good idea,
> >> because at least us, the maintainers, need at some point to be able
> > to
> >> test it if there is an issue with that minimum JDK.
> >>
> >> One thing to consider is which JDK is being required in the
> >> environment Ivy is being used: Ant, Gradle, SBT, Eclipse, Intellij…
> > We
> >> shouldn’t require too high.
> >>
> >> Nicolas
> >>
> >>> Le 18 mai 2017 à 10:58, J Pai <jai.forums2013@gmail.com> a écrit
:
> >>>
> >>> Now that the plan seems to be to release 2.5.x of Ivy, would it be
> >>> fine
> >> if we mandate the _minimum_ Java runtime version to be something
> >> higher than Java 5 that’s currently supported for 2.4.x
> >> http://ant.apache.org/ivy/history/latest-
> > milestone/compatibility.html.
> >>>
> >>> Given that Java 6 itself has long been EOLed, I’m not sure whether
> >>> we
> >> should consider that as minimum supported version or something
> > higher.
> >> Any thoughts?
> >>>
> >>> Things will be a bit more easy to develop and test once we finalize
> >>> on
> >> the Java version.
> >>>
> >>> -Jaikiran
> >>> -------------------------------------------------------------------
> > -
> >>> - To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org For
> >>> additional commands, e-mail: dev-help@ant.apache.org
> >>>
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org For additional
> >> commands, e-mail: dev-help@ant.apache.org
> >>
> >>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>


-- 
Matt Sicker <boards@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message