ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sarika Sinha" <sarika.si...@in.ibm.com>
Subject Re: Facing Issues with Ant 1.10.0
Date Tue, 17 Jan 2017 05:14:55 GMT

Thanks Stefan for the inputs, I could solve the other problems at Eclipse
IDE code level, but I am still stuck with
"missing stack frames while debugging Ant with breakpoints"

1.9.8 with Java 8 works fine but 1.10.0 is throwing error  when we try to
use ServerSocket and we get the exception
java.net.SocketException: Connection reset
	at java.net.SocketInputStream.read(SocketInputStream.java:209)
	at java.net.SocketInputStream.read(SocketInputStream.java:141)
	at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
	at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
	at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
	at java.io.InputStreamReader.read(InputStreamReader.java:184)
	at java.io.BufferedReader.fill(BufferedReader.java:161)
	at java.io.BufferedReader.readLine(BufferedReader.java:324)
	at java.io.BufferedReader.readLine(BufferedReader.java:389)

We used to get similar error when we we were using Java version less than
1.7 for Ant 1.9.6 or so.
Ant hints/suggestions will be of great help.

Thanks & Regards,
Sarika



From:	Stefan Bodewig <bodewig@apache.org>
To:	dev@ant.apache.org
Date:	01/09/2017 09:22 PM
Subject:	Re: Facing Issues with Ant 1.10.0



On 2017-01-09, Sarika Sinha wrote:

> I am trying to incorporate Ant 1.9.8 / 1.10.0 with Eclipse IDE.

> Has anyone faced a similar issue ? Or we already have some discussion on
> the similar line ?
> I could not find any related  bug on the Ant bugzilla.

You are the first person reporting such issues. I'm not an Eclipse user
(or any IDE user) at all, so I won't be able to help much.

> Where as 1.9.8 works fine with existing Ant framework in eclipse, having
> many issues with Ant 1.10.0 like below and some more
> - missing stack frames while debugging Ant with breakpoints
> - Getting error while using Ant 1.1.0 and Java 1.8 - Specifying an
> InputHandler is an Ant 1.5.* feature. Please update your Ant classpath to
> include an Ant version greater than this.

The later makes me suspect this is an Eclipse issue with the Eclipse
integration for Ant trying to parse Ant's version number by using the
first digit after the dot and assuming with 1 < 5 you must be using a
very old version of Ant. I don't think Ant can fix that.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org



Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message