ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <ddevie...@gmail.com>
Subject Re: Facing Issues with Ant 1.10.0
Date Mon, 09 Jan 2017 17:11:42 GMT
On Mon, Jan 9, 2017 at 4:52 PM, Stefan Bodewig <bodewig@apache.org> wrote:

> On 2017-01-09, Sarika Sinha wrote:
>
> > I am trying to incorporate Ant 1.9.8 / 1.10.0 with Eclipse IDE. [...]
> > Where as 1.9.8 works fine with existing Ant framework in eclipse, having
> > many issues with Ant 1.10.0 like below and some more
> > - missing stack frames while debugging Ant with breakpoints
> > - Getting error while using Ant 1.1.0 and Java 1.8 - Specifying an
> > InputHandler is an Ant 1.5.* feature. Please update your Ant classpath to
> > include an Ant version greater than this.
>
> The later makes me suspect this is an Eclipse issue with the Eclipse
> integration for Ant trying to parse Ant's version number by using the
> first digit after the dot and assuming with 1 < 5 you must be using a
> very old version of Ant. I don't think Ant can fix that.
>

Or maybe it's parsing 1.10 in base-2/binary, leading to 1.2 decimal, also <
to 1.5 decimal :)
Joking aside, that's a great hypothesis for the symptoms Stefan! Cheers,
--DD

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message