ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject IvyDE status (Was: VOTE Retire IvyDE)
Date Thu, 08 Dec 2016 09:45:35 GMT
I am forking the thread to not pollute the vote.

> Le 7 déc. 2016 à 19:56, Gintautas Grigelionis <g.grigelionis@gmail.com> a écrit
:
> 
> I decided to take a quick look at the build process and it's not broken per
> se, rather it's hardcoded to Eclipse SDK 3.7.1 foe Win32.

You confirm the doc is being correctly build ? If that effectively the case, it is good to
know, thank you for looking into it.
But one thing is broken for sure: the Ant targets to build IvyDE for the release, because
they still assert that the sources are being hosted in subversion.

> I would like to
> make the process to adapt to the build platform. Any suggestions for a
> reasonable Eclipse baseline? Should we target Java 8, that would be 4.5 (or
> maybe even 4.5.2).

Here is what is currently supported:
http://ant.apache.org/ivy/ivyde/history/trunk/compatibility.html <http://ant.apache.org/ivy/ivyde/history/trunk/compatibility.html>
It certainly can be reviewed.

As a general rule I would make IvyDE support the same version of the JVM as Ivy and Eclipse
does. A thing to note is that some IvyDE users are installing it in their IBM RAD editor,
so it would be nice to continue supporting if it doesn’t require much effort.

Nicolas


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message