ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Drop Support for Java5, Move on to Ant 1.10.0?
Date Mon, 21 Mar 2016 11:29:21 GMT
On 2016-03-06, Michael Clarke wrote:

> I personally don't think we should constrain ourselves to supporting End of
> Life'd versions of Java: anyone wanting to use an older version of Java can
> download an older version of Ant. That being said, Ant doesn't introduce
> major new features particularly often so we may not be losing too much by
> not using the latest Java APIs available to us.

Agreed on both points, I may even be seeing fewer new features
introduced than you do. :-)

> My preference would be to move our mainline development to compile against
> the current versions of Java with public support - so currently Java 1.8
> and 1.9 - with an increment in minor version number of Ant to reflect this
> change that may break some peoples' environments.

I'd translate that to Ant 1.0 and Java8 as a baseline.

> I also think we should consider creating a "Long Term Support" style
> branch for the previous version where we back-port fixes where
> possible - i.e. where any changed dependencies don't require a new
> version of Java, and the changed code hasn't used a new Java API and
> isn't specifically introducing new features.

While this technically isn't all too difficult I somewhat doubt we'll
find the time to do that. But we can certainly try.

I'll start a formal vote thread soon.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message