ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [VOTE] Ivy 2.4.0 Release - take 2
Date Sun, 14 Dec 2014 09:16:30 GMT
On 2014-12-13, Antoine Levy Lambert wrote:

> I am getting 2 errors :

I'm seeing the same errors and vaguely recall reporting the same issues
when I reviewed the last RC ...

I also vaguely recall suggesting XMLUnit back then :-)

Maybe I should stop whining and introduce XMLUnit, I'm supposed to know
a thing or two about that.  It's on my TODO list now, but burried at the
far end.

In addition I see a third error:

junit.framework.AssertionFailedError: expected:<1> but was:<0>
    at org.apache.ivy.plugins.circular.WarnCircularDependencyStrategyTest.testRemoveDuplicates(WarnCircularDependencyStrategyTest.java:60)

unfortunately this seems to be some sort of Heisenbug as the test passes
when I try to see what the two logged messages actually are.

Given the tests pass in the CI servers and already failed in earlier RCs
for me, this won't affect my vote.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message