ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject Java version of Ivy/IvyDE
Date Mon, 02 Sep 2013 08:37:20 GMT
Ivy and IvyDE are still supporting Java 1.4.

Java 1.4 is starting to be very old. And I am missing generics (I need them so much that I
do some generic-commenting [1]). So I suggest to require at least Java 5.

As discussed with the Java requirement of Ant, Java 5 is deprecated too, and I for instance
cannot run it anymore on my machine. So I would suggest to jump directly to require Java 6.

So what do you think ?
[ ] we should continue to support Java 1.4
[ ] we should make Ivy and IvyDE require Java 5
[ ] we should make Ivy and IvyDE require Java 6

Nicolas

[1] http://svn.apache.org/repos/asf/ant/ivy/core/trunk/src/java/org/apache/ivy/osgi/repo/ArtifactReportManifestIterable.java


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message