ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Matèrne (jhm) <apa...@materne.de>
Subject AW: Java version of Ivy/IvyDE
Date Mon, 02 Sep 2013 13:40:12 GMT
> I would vote for supporting Java 6 and then indicating on the website
> which ant + ivy/ivyDE version combination is needed to support pre-JDK
> 1.6 environments, especially given the argument about Ant requiring
> more recent JDK version.

+1
Like [1] for Ant.


> > As discussed with the Java requirement of Ant, Java 5 is deprecated
> too, and I for instance cannot run it anymore on my machine. So I would
> suggest to jump directly to require Java 6.

For Ant there wasn't a vote that I am aware of.
My last information is that Ant requires 1.5 [1], but there was a discussion [2] of moving
to 1.6.




> > So what do you think ?


[ ] we should continue to support Java 1.4 
[ ] we should make Ivy and IvyDE require Java 5 
[X] we should make Ivy and IvyDE require Java 6

As Jesse pointed out in [2] the actuals IDEs are requiring newer Java versions.
IvyDE is an IDE plugin so follow that.
For Ivy go the way as Ant wanted to go (but hasnt voted yet).

Jan

[1] http://ant.apache.org/faq.html#java-version
[2] http://ant.1045680.n5.nabble.com/Future-of-JDK-5-support-in-Ant-td5714291.html#a5714299


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message