ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Future of JDK 5 support in Ant
Date Fri, 19 Jul 2013 15:00:31 GMT
On 2013-07-18, Jesse Glick wrote:

> It has now been almost a year and a half since I called a vote to drop
> JDK 1.4 support for 1.9.0. Is anyone thinking about when to drop JDK 5
> support for running Ant itself, e.g. in 1.10.0 or whatever?

TBH I've been slacking with the 1.9.2 release and built it on Java6
keeping my fingers crossed, I don't have Java5 on any machine anymore.

OTOH 1.9.1 contained a fix to <jar> because the JARs created by 1.9.0
weren't properly readably on Java5 - something Jenkins kept telling us
but at least I didn't care enough to free up time and dig deeper.  We'll
lose the ability to catch those bugs even if we wanted to.

The new features for Java6 don't really appeal that much to me and I
think we don't have many features that requires anything beyond Java5 -
which might be more a sign of when we stopped to add new features than
of what the newer platforms have to offer.  Not sure.

That being said, I'm positive about moving on toe Java6 but see some
risks that I don't know how to cater for.  Java7 might be going too far
for me right now.

BTW

> ยท javax.script instead of having to depend on BSH

we already do that.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message