ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: JUnit4 requirement
Date Wed, 03 Apr 2013 04:14:46 GMT
On 2013-03-30, Michael Clarke wrote:

> https://github.com/mc1arke/ant/commit/63251494ed70b7694305e43c9cc37879ca3bd5adfixes
> this, providing CustomJUnit4AdapterCache is moved into the ant-junit4
> JAR. I can make a further commit to reverse the removal of the JUnit4 JAR
> and add the CustomJUnit4AdapterCache to the JAR then bundle it up into a
> patch if wanted?

I don't really have an opinion myself whether we still want to support
JUnit 3.x or not.  Nobody else either?

We could poll the users list but would likely get the usual mixed bag of
"go ahead, JUnit 4 has been available for X years" and "we cannot
upgrade for political reasons, JUnit 3 support is essential for us".

Given Ant 1.9.0 likely doesn't work with JUnit 3 we may wait a bit and
consider the lack of bug reports a sign that JUnit 3 compatibility isn't
needed anymore.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message