ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Glick <typr...@gmail.com>
Subject Re: Build failed in Jenkins: Ant-Build-Matrix » JDK 1.6 (latest),Windows #555
Date Wed, 06 Mar 2013 12:44:55 GMT
On 03/05/2013 11:13 PM, Apache Jenkins Server wrote:
>       [exec] [au:antunit] Build File: <https://builds.apache.org/job/Ant-Build-Matrix/./jdk=JDK%201.6%20(latest),label=Windows/ws/trunk\src\tests\antunit\taskdefs\exec\apply-test.xml>
>       [exec] [au:antunit] Tests run: 30, Failures: 0, Errors: 0, Time elapsed: 0.539
sec
>       [exec] [au:antunit] Target: testSrcfilePrefix took 0.002 sec
>       [exec] [au:antunit] Target: testRedirectorWithParallel took 0.002 sec
>       [exec] [au:antunit] Target: testLsPathParallel took 0.002 sec
>       [exec] [au:antunit] Target: testForce took 0.003 sec
>       [exec] [au:antunit] Target: testRedirector14 took 0.001 sec
>       [exec] [au:antunit] Target: testRedirector13 took 0.001 sec
>       [exec] [au:antunit] Target: testRedirector12 took 0.002 sec
>       [exec] [au:antunit] Target: testRedirector11 took 0.002 sec
>       [exec] [au:antunit] Target: testRedirector10 took 0.002 sec
>       [exec] [au:antunit] Target: testTargetfileSuffix took 0.001 sec
>       [exec] [au:antunit] Target: testRedirector9 took 0.001 sec
>       [exec] [au:antunit] Target: testNoRedirect took 0.001 sec
>       [exec] [au:antunit] Target: testRedirector8 took 0.002 sec
>       [exec] [au:antunit] Target: testRedirector7 took 0.001 sec
>       [exec] [au:antunit] Target: testRedirector6 took 0.001 sec
>       [exec] [au:antunit] Target: testIgnoreMissing took 0.002 sec
>       [exec] [au:antunit] Target: testRedirector5 took 0.002 sec
>
> file:///f:/hudson/hudson-slave/workspace/Ant-Build-Matrix/jdk/JDK%201.6%20(latest)/label/Windows/trunk/build/antunit/xml/TEST-src.tests.antunit.taskdefs.exec.apply-test_xml.xml;
lineNumber: 257; columnNumber: 1; XML document structures must start and end within the same
entity.

Indeed the file ends with

   <testcase name="testLsPath">
     <time>0.0020</time>
   </testcase>

with no closing </testsuite>. Perhaps the test itself somehow kills the test runner?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message