ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Glick <>
Subject [VOTE] Drop JDK 1.4 after 1.8.3
Date Fri, 27 Jan 2012 18:42:14 GMT
As suggested in 1.8.3 thread, I propose we drop JDK 1.4 support in trunk after Ant 1.8.3 is
released. It is long past EOL 
<> and cumbersome to even get
installed for testing. (Note that JDK 5 is also past EOL, but I am not proposing 
dropping JDK 5 support in this vote.)

Switching trunk sources to assume JDK 5 would, among other things, permit use of generics
to make code clearer. It is also possible that annotations could be used to 
document tasks/types and their configuration. And of course there are various API enhancements
that may be of use; a search for "jdk1.5" in build.xml shows some things 
that could be simplified, and there is likely more that would be used if it were easy to do

[X] +1: announce that 1.8.3 will be the last version of Ant to support JDK 1.4, and after
it is branched, permit trunk sources to assume JDK 5+, updating CI jobs accordingly
[ ] ±0: not sure, maybe continuing to support JDK 1.4 is useful, leave it alone for now
[ ] -1: please no, we still need to support JDK 1.4 in 1.8.4 or 1.9

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message