ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: 1.8.3?
Date Fri, 20 Jan 2012 16:54:23 GMT
On 2012-01-20, Tushar Kapila wrote:

> I got java 1.4 from Oracle/ old sun java site for windows and got it
> running for a test app.

I didn't realize there are Windows/Linux versions of 1.4.2_19 and older,
I just looked at the later 1.4.2 versions and they are availabe for
Solaris only.  I may try to get the Linux version working on my machine.

> Can you share the command to get the latest ant code?

> I tried
> svn co https://fisheye6.atlassian.com/browse/ant/core/trunk ant


> svn co http://svn.apache.org/repos/asf/ant/ant/trunk ant
> (svn: Repository moved permanently to '/viewvc/ant/core/trunk/'; please
> relocate)

You may want to use https instead.

We know Ant builds with 1.4 - we have a CI build that verifies build and
test there.

But if I create a release using, say, OpenJDK 1.6 it is possible javac
resolves some method invocations to methods that are present in Java6
but not in 1.4.  This is why the release process of Ant has been a
staged process so far where you start with the lowest JDK needed to
support, then compile the remaining classes with the next higher version
and so on until you reach the highest version required by an optional
task or type.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message