ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@hibnet.org>
Subject IvyDE updatesite and the cleanup of www.apache.org/dist
Date Sun, 25 Sep 2011 14:29:33 GMT
I am looking closely to how to resolve IVYDE-281 [1]. The issue is about listing several versions
of Ivy and IvyDE to the end user in Eclipse, and having only the last stable version on www.apache.org/dist
whereas the others would be on archive.apache.org.

We currently have an "old-style" updatesite, supported be every Eclipse 3.x version. We should
migrate it to a "P2" updatesite to support our requirement, but P2 is only supported by Eclipse
3.5 or superior.

For now IvyDE required Eclipse 3.2 or superior. And we agreed that the next version of IvyDE
will require Eclipse 3.4 at least.

I think it maybe technically possible to maintain a P2 with an old style updatesite together,
with the same updatesite url. But it seems quite painful.

I suggest we change our updatesite to be P2 only, thus requiring Eclipse 3.5. But for those
who still have an Eclipse 3.4, they will still be able to install IvyDE, but the manual way
[2].

Any objection ?

Nicolas

[1] https://issues.apache.org/jira/browse/IVYDE-281
[2] http://ant.apache.org/ivy/ivyde/history/latest-milestone/install.html#manual


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message