ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Benson <gudnabr...@gmail.com>
Subject Re: Ant Plugins - ant version compatibility
Date Mon, 20 Jun 2011 20:53:34 GMT
On Mon, Jun 20, 2011 at 10:02 AM, Michael Nellis <mrnellis@us.ibm.com> wrote:
> Jesse Glick <jesse.glick <at> oracle.com> writes:
>>
>> On 06/20/2011 09:40 AM, Michael Nellis wrote:
>> > I am investigating how to determine whether an Ant plugin,
>> > built with Ant 1.8.1, will work with Ant 1.8.2.
>>
>> Do you mean an Ant task? Generally it should work this (not the reverse of
> course), though specific
>> incompatibilities ought to be mentioned in the changelog.
>>
>
>
> I should have qualified my question a bit better.
> I have a set of Ant listeners that I need to make sure works from version to
> version.
>

These should always work with later versions.  The Ant developers take
backward compatibility very seriously, in preference to probably any
other concern.

Matt

>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message