ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Glick <jesse.gl...@oracle.com>
Subject Re: warning: 'includeantruntime' was not set
Date Wed, 18 Aug 2010 21:21:10 GMT
On 08/18/2010 02:27 PM, Matt Benson wrote:
> I would still guess that more builds than not DON'T need to compile against Ant itself.

Of course; at least an order of magnitude more. But those that do will be *broken* if your
suggested change is made, whereas those that don't get a *warning* currently. 
My inclination was to err on the conservative side and retain compatibility even at the cost
of a little inconvenience.

Call a vote if you want to change the default and break compatibility. 1.8.0 and 1.8.1 have
the warning, so a break in 1.8.2 would only affect those who ignored the 
warning for two prior releases. I don't know if Ant generally has a policy for fixing stupid
historical defaults, like failonerror=false.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message