ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject AW: Does ant 1.8.0 compile on Solaris 10 SPARC?
Date Wed, 31 Mar 2010 04:50:26 GMT
I never had tried to build Ant on Solaris - because I have no such system ;-)
So these are my opinions:
- Ant should be buildable on Solaris too
- Ant requires Java 1.4+
- Ant does not require any external libs for building - if not present it skips these classes/jars

So 
- download the sources
- hava a JDK 1.4+ on your PATH (or the Solaris equivalent ;-)
- place the external jars in your ANT_SOURCES/lib directory
- open a shell in your ANT_SOURCES directory (the dir where Ants buildfile is)
- start "build dist"

This uses the "build.sh" wrapper which
- starts "bootstrap.sh" for compiling the most required Ant classes directly via javac
- builds a distribution using these compiled classes


Jan

>-----Ursprüngliche Nachricht-----
>Von: J. Joseph Felten [mailto:jjfelten@googlemail.com] 
>Gesendet: Dienstag, 30. März 2010 16:27
>An: Ant Developers List
>Betreff: Re: Does ant 1.8.0 compile on Solaris 10 SPARC?
>
>Security concerns; otherwise personally I would love to.
>
>On Tue, Mar 30, 2010 at 1:09 PM,  <Jan.Materne@rzf.fin-nrw.de> wrote:
>> Why cant you use the binary version?
>> http://ant.apache.org/bindownload.cgi
>>
>>
>> Jan
>>
>>>-----Ursprüngliche Nachricht-----
>>>Von: J. Joseph Felten [mailto:jjfelten@googlemail.com]
>>>Gesendet: Montag, 29. März 2010 15:17
>>>An: dev@ant.apache.org
>>>Betreff: Does ant 1.8.0 compile on Solaris 10 SPARC?
>>>
>>>Has anyone successfully built ant 1.8.0 on Solaris 10 SPARC (u4,
>>>sun4u)?  I actually wanted to compile the latest Tomcat on a 
>server on
>>>a private network, but building Tomcat requires ant >= 1.6 
>and the ant
>>>that comes with Solaris 10 is 1.5.4, so I downloaded the ant 1.8
>>>source and moved it over but get 51 errors from build.sh.  I thought
>>>perhaps it was due to the Java 1.5.0 JDK on that server so I 
>installed
>>>the latest 1.6 JDK but get the same errors.  JAVA_HOME is set.  Am I
>>>missing some libraries?  I just want to get Tomcat compiled so I know
>>>little about ant and have never had to try to build it 
>before.  I also
>>>tried the bootstrap.sh script which yields the same errors.  
Thanks in
>>>advance and I apologize if this is not the correct forum for this
>>>question.
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
>For additional commands, e-mail: dev-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message