ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Reilly <peter.kitt.rei...@gmail.com>
Subject Re: Gertting "Reference <ejb.classpath> not found" while using Ant 1.8 RC1
Date Thu, 28 Jan 2010 09:56:30 GMT
When using ant 1.7, did you see a warning about references?

Peter

On Thu, Jan 28, 2010 at 9:12 AM, Suman N <Suman.N@curamsoftware.com> wrote:
> Hi,
>
>
>
> We are testing the compatibility of our build scripts with Ant 1.8 RC1 and
> we encounter the following error when referring a path refid in our script.
>
>
>
>
>
> D:\CC\suman.n_TI_MAIN_3\TIVOB\build_scripts\test.xml:579: The following
> error occurred while executing this line:
>
> D:\CC\suman.n_TI_MAIN_3\TIVOB\build_scripts\test.xml:632: The following
> error occurred while executing this line:
>
> D:\CC\suman.n_TI_MAIN_3\TIVOB\build_scripts\test.xml:672: The following
> error occurred while executing this line:
>
> D:\CC\suman.n_TI_MAIN_3\TIVOB\build_scripts\test.xml:703: Reference
> ejb.classpath not found.
>
>
>
> We are defining a path element in the ‘wlstest’ target (Line 573 in attached
> test.xml)
>
>
>
>
>
>
>
> <target name="wlstest"
>
>           description="Runs in-container tests against WLS and produces a
> report.">
>
>
>
>     <antcall target="clean" inheritAll="false"/>
>
>
>
>     <path id="ejb.classpath">
>
>       <pathelement location="${WLS_HOME}/lib/weblogic.jar"/>
>
>     </path>
>
>
>
>     <!-- 36877: Must set inheritall to true here, or the test failure
> override
>
>          does not get propagated and clover fails before producing a report.
> -->
>
>     <antcall target="wlstest.without.clean" inheritAll="true"/>
>
>
>
>   </target>
>
>
>
>
>
> We refer to this “path” in another part of the build script: (line 719 in
> the attached test.xml file)
>
>
>
>       <classpath>
>
>         <path refid="junit.common.classpath"/>
>
>         <path refid="ejb.classpath"/>
>
>         <path refid="zos.ejb.classpath"/>
>
>         <path refid="nas.ejb.classpath"/>
>
>         <pathelement path="${jar.wsdl4j}"/>
>
>         <!-- stubs of the beans -->
>
>         <pathelement path="${dir.test.lib}/stubs.jar"/>
>
>       </classpath>
>
>
>
> The build script basically tests all the tests which depend on the
> application server (Oracle weblogic in this case).
>
> This error does not occur when using Ant 1.7.0 version.
>
> Can  you please let me know what has changed in Ant 1.8 RC1 that is causing
> the issue. Please let me know the workaround or fix for this?
>
>
>
> Cheers,
>
> Suman.N
>
> The information in this email is confidential and may be legally privileged.
> It is intended solely for the addressee. Access to this email by anyone else
> is unauthorized. If you are not the intended recipient, any disclosure,
> copying, distribution or any action taken or omitted to be taken in reliance
> on it, is prohibited and may be unlawful. If you are not the intended
> addressee please contact the sender and dispose of this e-mail. Thank you.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message