ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject 1.8.0RC1: build test
Date Wed, 06 Jan 2010 10:26:32 GMT
Downloaded the src-distro, extracted with Winzip.
Classpath not set.
Path=C:\Programme\Perl\bin\;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32
\Wbem;c:\bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.pl

Java:
Java-Home: c:\jdk\142_15
java version "1.4.2_15"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_15-b02)
Java HotSpot(TM) Client VM (build 1.4.2_15-b02, mixed mode)

Build-Command: build test

.....

[junit] Testcase:
testAtLeast(org.apache.tools.ant.taskdefs.condition.AntVersionTest):
Caused an ERROR
[junit] Should be at least 1.7
[junit] C:\...\src\etc\testcases\taskdefs\conditions\antversion.xml:21:
Should be at least 1.7


[junit] Testcase:
testExactly(org.apache.tools.ant.taskdefs.condition.AntVersionTest):
Caused an ERROR
[junit] Should be exactly 1.8.0
[junit] C:\...\src\etc\testcases\taskdefs\conditions\antversion.xml:32:
Should be exactly 1.8.0


[junit] Testcase:
testOnlyOneInstance(org.apache.tools.ant.util.ClasspathUtilsTest):
FAILED
[junit] Should be only one and not 2
file:/C:/.../src/main/org/apache/tools/ant/taskdefs/defaults.properties
jar:file:/C:/.../bootstrap/lib/ant.jar!/org/apache/tools/ant/taskdefs/de
faults.properties
[junit] junit.framework.AssertionFailedError: Should be only one and not
2
file:/C:/.../src/main/org/apache/tools/ant/taskdefs/defaults.properties
jar:file:/C:/.../bootstrap/lib/ant.jar!/org/apache/tools/ant/taskdefs/de
faults.properties
[junit]     at junit.framework.Assert.fail(Assert.java:47)
[junit]     at junit.framework.Assert.assertTrue(Assert.java:20)
[junit]     at
org.apache.tools.ant.util.ClasspathUtilsTest.testOnlyOneInstance(Classpa
thUtilsTest.java:65)


[junit] Testcase:
testGetXyzSource(org.apache.tools.ant.util.LoaderUtilsTest):      FAILED
[junit] expected:<...bootstrap\lib\ant.jar> but was:<...src\main>
[junit] junit.framework.ComparisonFailure:
expected:<...bootstrap\lib\ant.jar> but was:<...src\main>
[junit]     at junit.framework.Assert.assertEquals(Assert.java:81)
[junit]     at junit.framework.Assert.assertEquals(Assert.java:87)
[junit]     at
org.apache.tools.ant.util.LoaderUtilsTest.testGetXyzSource(LoaderUtilsTe
st.java:40)



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message