ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: failing test cases in the build of ant 1.8.0RC1
Date Wed, 06 Jan 2010 11:00:56 GMT
On 2010-01-06, Stefan Bodewig <bodewig@apache.org> wrote:

> On 2010-01-06, Antoine Levy Lambert <antoine@gmx.de> wrote:

>> About AntClassLoader5Test, I do not know whether this has to do with
>> that, but I did the build in the following way :

>> - first pass building everything with JDK 1.4. Then build with JDK
>> 1.5. It looks like we have only 3 classes which require JDK 1.5.

>> I ran the tests under JDK 1.5.

> Truth be told, I've never run the build under Java5 only Java6, will try
> later today.

I see the same error if I bootstrap trunk with Java 1.4 and run the test
with 1.5 (which compiles AntClassLoader5 and re-creates
ant-nodeps.jar).  Once I copy over ant-nodeps.jar to bootstrap/lib
things look fine.

"./build.sh test" really runs tests against the version you've
bootstrapped, at least if classloaders are involved since ant.jar will
be loaded from there.

I'll run the testsute against the binary distribution you've created
later today.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message