ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject Re: [antunit] A fail task
Date Wed, 21 Oct 2009 05:32:56 GMT
On 2009-10-17, Nicolas Lalevée <> wrote:

> I have some use case where I need to fail no matter what. Basically I
> need a task corresponding to the junit.framework.Assert#fail().

> To implement it I suggest we implement it like the fail Ant
> task. Actually I suggest to rename "assertTrue" to "fail" in the
> antlib.xml

I wanted to shout stop here until I saw the last part of the sentence.

> (or "failure", "testFail" to not conflict with Ant's fail task ?),

No reason to do that, they live in different XML namespaces.

> change the AssertTask so it will throw the AssertionFailedException if
> no condition is provided, and add a macro for assertTrue.

Fine with me.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message