ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maarten Coene <maarten_co...@yahoo.com>
Subject Re: 2.1.0 rc 2 fails resolve with private repo using basic auth
Date Thu, 06 Aug 2009 21:32:06 GMT

Chris,

I think I've found the problem and committed a fix in SVN trunk.
Could you give it a try and tell me if it worked so we can fix this for the 2.1.0 final release
as well?

Maarten




----- Original Message ----
From: Chris Marks <topher1120@gmail.com>
To: dev@ant.apache.org
Sent: Thursday, August 6, 2009 7:36:33 PM
Subject: 2.1.0 rc 2 fails resolve with private repo using basic auth

Hi,
I have a private Maven repository running JFrog Artifactory that I have been
using successfully with 2.1.0 rc1.  However, rc2 appears to be failing to
resolve dependencies because it can't authenticate against Artifactory.  In
looking at the documentation for the Ant task, I haven't seen the attribute
to increase the logging, but the message reported through Ant is below:

[ivy:resolve] Aug 5, 2009 10:46:10 PM
org.apache.commons.httpclient.auth.AuthChallengeProcessor
selectAuthScheme
[ivy:resolve] INFO: Basic authentication scheme selected
[ivy:resolve] Aug 5, 2009 10:46:10 PM
org.apache.commons.httpclient.HttpMethodDirector processWWWAuthChallenge
[ivy:resolve] INFO: No credentials available for BASIC 'Artifactory
Realm'@mavenhost:80

Rolling back to rc1 resolves this issue and dependencies are downloaded as
expected.  Artifactory uses basic authentication with the realm named
"Artifactory Realm".

I did a search in JIRA, but did not see a similar issue listed.  I thought I
would check with this list before logging an issue.  Please let me know if
there is more information I can provide to help clarify the problem.

Thanks,
topher



      

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message