ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GregP <greg.pascu...@cgi.com>
Subject Getting prompted for ssh password regardless of cvspass tag
Date Wed, 18 Mar 2009 21:28:09 GMT

Good Afternoon,

I am using ANT v1.5 being called from a bash script which passes in the
user.id and password through a command line call.

The following two lines exist in my build.xml file:
1)  <cvspass cvsRoot=":${cvs.conn.type}:${user.id}@${cvs.host}:<some
repository>" password="${password}" passfile=".cvspass" />
2)  <cvs cvsRoot=":${cvs.conn.type}:${user.id}@${cvs.host}:<some
repository>" failonerror="true" passfile=".cvspass" cvsRsh="ssh"
command="export -r HEAD" package="<some package>" dest="${source.dir}" />

Some background: The user executing the build is prompted to enter their
username and password so that ssh has the credentials required to export the
repository. I have echoed the various variables and the contain the proper
information.

My connection type is EXT.

The .cvspass file does not contain windows line terminators. The path to the
.cvspass file seems to be correct.

Yet, it still prompts me to enter the password!

Here is a snippet of the output:
init:
     [echo] ... Creating Build Directory ...
    [mkdir] Created dir: <path to dir>/build

checkOutSource:
     [echo] ... Checking Out <some package> From CVS ...
     [echo] ... Preparing for auto password authentication ...
      [cvs] Using cvs passfile: /<path to cvs>/.cvspass
<username>@<host>'s password:

Any help with this would be most welcome.

Thank you

Greg
-- 
View this message in context: http://www.nabble.com/Getting-prompted-for-ssh-password-regardless-of-cvspass-tag-tp22588917p22588917.html
Sent from the Ant - Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message