ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Java version required for trunk
Date Wed, 15 Oct 2008 04:31:21 GMT
Hi all,

this is not a vote, more of a poll to see whether there'd be a chance
for consensus.

Ant 1.7.1 dropped support for Java 1.2 somewhat officially, we voted
to drop support but never made that decision public.

There has been some discussion about dropping support for Java 1.3 in
trunk.  One of the aguments against it was that 1.4 doesn't offer
anything new and going from 1.3 to Java5 was too big a step.

Given that nobody of us really works works with Java 1.3 anymore,
trunk doesn't get tested there at all.  So even if 1.4 doesn't offer
much, officially dropping support for 1.3 would make us match the
supported environments to the tested environments more closely.

So what do you think?  Do we want to move to 1.4?  Would you be more
comfortable with it after a Java 1.3 compatible Ant 1.7.2 with most
bug fixes from trunk applied?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message