ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Reilly" <peter.kitt.rei...@gmail.com>
Subject Re: Compiling fails on JDK 1.3
Date Tue, 14 Oct 2008 09:13:26 GMT
On Tue, Oct 14, 2008 at 8:40 AM, Stefan Bodewig <bodewig@apache.org> wrote:
> On Tue, 14 Oct 2008, Jan Materne <Jan.Materne@rzf.fin-nrw.de> wrote:
>
>> I found the vote that we dropped Java 1.2
>> http://marc.info/?l=ant-dev&m=117794737813795&w=2
>
> Great, thanks.
>
>
>> Should we post these info in a more prominent place instead of a
>> mailinglist-search?
>
> absolutely, and we probably should have listed it as a breaking change
> in Ant 1.7.1

The issue was that ant 1.7.0 could not be used with jdk1.2. This was found
after the release of 1.7.0, and was due to the fact that the java5
javac compiler
is unable to generate correct bytecode for 1.2. - so the breaking change
is in Ant 1.7.0.

Peter

>
>> Like FAQ?
>
> Will do, alongside a comment that we don't really test old Java
> releases and only ensure that Ant compiles there.
>
> I'll also start a different thread for the Java version required by
> trunk.  Do you want to fix the JDK 1.3 issues in trunk (I don't have a
> 1.3 JDK around anymore and am too lazy to install one right now) or
> should we wait for the thread's outcome?
>
> Stefan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message