ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <foamd...@gmail.com>
Subject Re: Java version required for trunk
Date Wed, 15 Oct 2008 05:00:59 GMT
Hi,

> There has been some discussion about dropping support for Java 1.3 in
> trunk.  One of the aguments against it was that 1.4 doesn't offer
> anything new and going from 1.3 to Java5 was too big a step.

I'd personally argue that Java5 doesn't really offer very much apart
from window dressing, but I know I'm in the minority.

> So what do you think?  Do we want to move to 1.4?  Would you be more
> comfortable with it after a Java 1.3 compatible Ant 1.7.2 with most
> bug fixes from trunk applied?

There should be an announcement on the users list regardless of what
is decided.  My 'non-vote' would be to make 1.8 the Java 1.4+ version
and retain 1.3 compatibility (as much as we can) for 1.7.2

Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message