ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey E Care <ca...@us.ibm.com>
Subject Re: Java version required for trunk
Date Wed, 15 Oct 2008 11:31:37 GMT
Stefan Bodewig <bodewig@apache.org> wrote on 10/15/2008 12:31:21 AM:

> [snip]
>
> There has been some discussion about dropping support for Java 1.3 in
> trunk.  One of the aguments against it was that 1.4 doesn't offer
> anything new and going from 1.3 to Java5 was too big a step.
> 
> Given that nobody of us really works works with Java 1.3 anymore,
> trunk doesn't get tested there at all.  So even if 1.4 doesn't offer
> much, officially dropping support for 1.3 would make us match the
> supported environments to the tested environments more closely.
> 
> So what do you think?  Do we want to move to 1.4?  Would you be more
> comfortable with it after a Java 1.3 compatible Ant 1.7.2 with most
> bug fixes from trunk applied?

I think moving to 1.4 is fine; I'm actually kind of surprised that we've 
even go that low. Do we have a sense that people are still out there in 
the wild using JDK 1.4?

I'd be fine with JDK 5
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message