ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Kruithof ...@kruithof.xs4all.nl>
Subject Re: Java version required for trunk
Date Sun, 19 Oct 2008 12:35:11 GMT
Hello

I know i have not been really active for some time now (changed house, 
then job) yet I manage to remember previous discussions.

I still feel that the following reasoning is flawed:
>> There has been some discussion about dropping support for Java 1.3 in
>> trunk.  One of the aguments against it was that 1.4 doesn't offer
>> anything new and going from 1.3 to Java5 was too big a step.
>>     
I do think the problem is that we cannot support a whole lot of java 
versions for every new version of ant, just because of the amount of 
work associated with testing it all.
The choice should not only be based on what new language features are 
offered by a java version, but also the number of java version we have 
to test against.
If companies/projects/products have a good reason to stay with older 
java versions, the older version of ant that is supported has done all 
this time, and I think we should expect from companies that stay with 
older java versions that these companies shall bear the consequence of 
not being able to run the newest ant.

Maybe we should consider dropping java versions even somewhat faster, I 
don't see the point in supporting java versions that SUN does not 
support anymore for the general public.

 From the sun website:
http://java.sun.com/products/archive/eol.policy.html
Revised (Current) Java SE Support Road map
Release Family 	GA Date 	EOL Notification 	EOSL 	Support Period
1.4 	February, 2002 	December, 2006 	October 30, 2008 	6 ½ years
------------------------------------------------------------------------
5.0 	May, 2004 	April, 2008 	October 30, 2009 	5 ½ years
------------------------------------------------------------------------
6 	December, 2006 	2009* 	2010* 	4 years*


These dates seem to be reasonable to stop supporting the corresponding 
java release in an upcoming ant release
(if ant 1.8 appears after october 30, 2008 the 1.8 range should support 
5.0 and 6 and possibly 7)

We in turn we could consider to prolong the life of the point releases 
for critical updates to have at lease one ant version operating with the 
java version upto the state EOSL from SUN.

Bugs eligible to be solved on the point releases after a new major 
release has been done would have to come from customers running a java 
version that is not supported by a more recent ant release, running a 
java version that is still supported by SUN, these should also be real 
bugs, not feature requests, and the company shall have to test the ant 
release towards the old java version and provide us the logs, especially 
if we do not have the possibility to run the old java version anymore. 
(This because I am quite sure that in 10 years java 1.4 won't be running 
anymore on the "current" hardware and operating systems.)

Java SE for Business support road map
Release Family 	GA Date 	EOL Notification* 	EOL* 	EOSL* 	Support Period
1.4 	February, 2002 	April, 2008 	April, 2013 	April, 2018 	16 years
------------------------------------------------------------------------
5.0 	May, 2004 	June, 2009 	June, 2014 	June, 2019 	15 years
------------------------------------------------------------------------
6 	December, 2006 	June, 2011 	June, 2016 	June, 2021 	15 years



br Martijn

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message